Visual Studio Online support

Sep 11, 2014 at 1:54 PM
I managed to connect to Visual Studio Online (in the Administration area), but am unable to see any links to issues. Does this plugin work with Visual Studio Online?
Sep 11, 2014 at 6:02 PM

The last time I touched the code it was working fine (there are some tests which check against my own instance of VSO) but I haven't checked in a while, so VSO connection strings might have changed, they might have upgraded their TFS version, ...

I'll check as soon as I have a chance but you can already do that yourself using the tests in the solution, which you need to point at your instance and configure your credentials.

Sep 11, 2014 at 7:10 PM
I confirm that the integration between the .NET part of the plugin and VSO still works, I can't tell about the Java part of the plugin but it hasn't changed in a long time and assuming that the TeamCity APIs have preserved backwards compatibility over time it should work as well.

Some obvious things to check:
  • make sure you're using the version of the plugin matching your TeamCity version
  • make sure you read the "how it works" section of the project homepage as it explains why performance can be particularly bad and may take a while the first time you load the issues
Sep 11, 2014 at 7:16 PM
One more thing to check is that the .NET process runs fine when executed by TeamCity as some failures may not be reported (i.e. .NET 4.5 is not installed). If you have access to the server running TeamCity, using process explorer or similar tool you can check that TfsWrapper.exe processes are executing and you can also invoke the executable manually with the same parameters to check that you get a result back on the stdo. Watch out that by default, for performance reasons, it uses .NET remoting with a main TfsWrapper process which handles the communication with TFS and many satellite TfsWrapper processes interacting with the main one and reporting back to TeamCity.
Sep 12, 2014 at 8:56 AM
Configuring works (I can use the Test button succesfully), but linking issues to changes still fails. I've tried on TeamCity 9 EAP, as well as on TeamCity 8.1.2.

Here's what I observe:
  • The TfsWrapper.exe processes are executing. Also tried running them manually and I get data back from Visual Studio online
  • The teamcity-server.log contains several entries like this when executing a build. This being a warning I'm not sure it's relevevant,but it's all I can find.
WARN - Invalid issue-tracker connection "VSO" settings: the pattern should not match empty string
Sep 12, 2014 at 9:06 AM

What do you mean with linking issues to changes still fails? The linking happens in TFS, when you commit associating the commit to one or more work items.

Can you see when invoking the command line manually that when you ask for issues for a specific commit they are returned?

Sep 12, 2014 at 9:12 AM
Yes, issues are returned when invoking the command manually.

Problem is nowhere in the TeamCity UI I see the issues appear.
Sep 12, 2014 at 9:15 AM
So, what doesn't work exactly? :)

Sep 12, 2014 at 9:17 AM
Edited Sep 12, 2014 at 9:22 AM
I was expecting, just like YouTrack issue tracker integration, to see links to TFS issues appear in the changes list of a project. Unfortunately, I don't see them.

In other words, this part of the plugin description does not seem to work: "Work item details will appear alongside any changeset associated to it directly in the TeamCity UI."
Sep 12, 2014 at 9:35 AM
Ok I see, I guess the problem might be in the TeamCity side of the plugin then, which hasn't changed much for years. My problem is haven't been using TeamCity together with TFS in a long time and it will take some time to set the whole thing up. You work for JetBrains right? Would you like taking over the project, as I obviously can't support it properly?

Sep 12, 2014 at 9:37 AM
That is correct, on the evangelist side. I'll clone the plugin and try to figure out what's going on inside and make a contribution if I can find anything.
Unfortunately wil not be possible to take it over, but I'll ping the team on this.

Thanks so far!
Sep 12, 2014 at 1:22 PM

Hi Marteen,

I took some time to set up TeamCity with TFS and everything worked fine. Here’s more or less what I did:

  • configure the plugin in the TC admin area using as the url and my VSO alternate credentials
  • test that retrieving a work item by id worked
  • configure a new project and a build type with VSO TFS as a VCS root, again using as the url and my alternate credentials, this time with ##LIVE##\simoneb as the user though (as shown in the caption below the textbox in the TC UI). I also configured $/IssueTrackingSandbox as the root path (this is the same of one of the projects inside the collection)
  • commit a change associating it to an existing work item
  • click on the Issue Log tab in the build configuration UI, and I get a list with the last build and the associated work item

Inline image 1

Sep 12, 2014 at 1:25 PM
Looks like I cannot attach images, nevermind. Just to show what I was seeing. Once you click on the Issue Log tab for the first time it should take a bit, for the reasons explained in the "How it works" section, but if you're patient it should work then ;)
Sep 12, 2014 at 1:44 PM
Got it! Did not see it displayed at first.