Test connection works, but no issues are shown for builds

Dec 13, 2013 at 11:19 AM
Hi,

I set up Tfs TeamCity issue tracker (#8.x-7), on our TC 8.0.5 installation point at a TFS 2012 Instance.

The connection test works fine, but in the builds, no issues are shown. Is there any way to debug the issue retrieval, is there a log? I couldn't find anything useful in the TeamCity log files.
Coordinator
Dec 13, 2013 at 12:48 PM
There should definitely be entries in the logs coming from the plugin. Look into the teamcity-vcs log files and see if you can find anything in there.
Dec 13, 2013 at 2:00 PM
When I search for "issue" I find some entries with errors which were logged when I was setting the plugin up and had the wrong TFS URL.

What should I search for? There are plenty of "LoadChanges" log entries, but don't see anything regarding the issues, though this might just be because the file is not exactly small, and I don't know what to look for exactly.
Coordinator
Dec 14, 2013 at 11:48 PM
To start with, I would look for ERROR entries, they should be fairly visible because they should contain the stacktrace/command line arguments used to invoke the command, in case it failed.

By the way, testing the connection works in the sense that you enter a work item ID and its details are shown successfully in the test dialog?
Dec 17, 2013 at 12:25 PM
Cannot find any errors in the log file. Is there a way to tell if the import even tried to run?

And yes, testing the connection means, I get the item details when entering an issue id in the test dialog.
Coordinator
Dec 17, 2013 at 12:42 PM
I guess nothing is logged if there are no errors, what you could do instead is log into the server box and check the running processes, if the initial load is happening you should see several processes running the TfsWrapper.exe executable.

Please consider that if the TFS server is huge the initial load could take quite a long time, to understand why please check the How it Works section in the homepage, where I explained in detail why this necessarily happens.
Dec 17, 2013 at 1:16 PM
I'm sorry, I should have been more precise: There is not even an issues tab!


These are the tabs for a build I attached an issue to:
Image

And this is the test:
Image
Coordinator
Dec 17, 2013 at 1:21 PM
I see, it's quite tricky to troubleshoot from here, what I'd do is try from scratch, then once you've enabled the plugin do a commit to TFS associating a work item, if it still doesn't work the best thing is to probably check if any TfsWrapper process is being created on the server at all.